TSL60 stopped making sound

CK_Killinger

New Member
Joined
Feb 13, 2021
Messages
5
Reaction score
15
Can anybody refer me to a great amp repair shop in Los Angeles? I bought a used TSL 60 last year and last night I could smell an abnormal order and it stopped making sound.

Hoping it just needs tubes and bias. Any mods I should consider
Thanks!
 

Spanngitter

Well-Known Member
Joined
Jan 22, 2019
Messages
268
Reaction score
275
Location
Upper Palatinate / Bavaria
Unfortunately I cannot give you and advice for LA based techs but the description "I could smell an abnormal order" would indicate to me that the typical issue (HV Caps on Mainboard did puke out their life) has occured on your TSL and there might be more required then "tubes and bias".
I'll keep my fingers crossed that the PCB is not too badly damaged and it can be revitalized with a set of new 330uF/350V Caps...
 

fitz288

Well-Known Yinzer
Gold Supporting Member
Joined
Apr 7, 2020
Messages
6,092
Reaction score
16,474
Location
the Burgh
Can anybody refer me to a great amp repair shop in Los Angeles? I bought a used TSL 60 last year and last night I could smell an abnormal order and it stopped making sound.

Hoping it just needs tubes and bias. Any mods I should consider
Thanks!
If you can't find a recommendation, check the Marshall site for authorized service.
Change the checkbox from "Retailer" to "Service Center", and put in your ZIP code.

A quick search for LA pops up with this:
1659612850511.png

It worked for me - I found a great tech in Pittsburgh.
 

CK_Killinger

New Member
Joined
Feb 13, 2021
Messages
5
Reaction score
15
Gratitude for taking the time to reply and for sharing your knowledge and experience!!
 


Top